[Normas] Posteo en esta sección PHP 5.6+

  • 0 Respuestas
  • 851 Vistas

Valarjar
Hijo de Odyn

[Normas] Posteo en esta sección PHP 5.6+
« en: Marzo 10, 2017, 03:10:03 am »
Hola a todos,

Creo esta norma de posteo debido a que todo el mundo supongo que quiere un foro actualizado con nuevas tecnologías, pues bien, pongo esta norma. La última versión de php que tiene un soporte extendido es la 5.6 , todas las anteriores son DEPRECATED, la versión 5.6 fue creada el 20-08-2014 y su soporte acabará para el   31-12-2018. La versión anterior que es la 5.5 queda obsoleta este junio de 2016, quedando inútil sus versiones.

Llegados a este punto, entenderéis porque quiero solo código en esta versión, es debido a su caducidad, lo ideal sería postear en la versión 7.0 (que es la mas reciente y con mejor rendimiento).

A continuación os pongo una tabla de las versiones de php con sus cualidades:



Vamos a poner un ejemplo:

Código: [Seleccionar]
mysql_connect()

Esta es una función de php para conectarte con bases de datos mysql, esta deprecated obsoleta en php5.5 y eliminada en 7.0 ; Este tipo de funciones y programación estarían betadas en este foro. En su lugar deberíamos utilizar la siguiente función:

MySqli:

Código: [Seleccionar]
Normal:
mysqli_connect()

OOP:
$mysqli = new mysqli();

PDO:

Código: [Seleccionar]
Normal:
PDO::__construct()

OOP:
$pdo = new PDO();
« Última modificación: Marzo 31, 2017, 15:03:05 pm por Valarjar »